To configure OSPF for a small enterprise with 4 routers.
1) Give east and west pc's valid IP addresses.
2) Run the commands below on the specified router.
enable
config t
hostname Paul-Border-Router1
interface GigabitEthernet 0/0
no shutdown
ip address 10.8.1.1 255.255.255.248
exit
router ospf 1
network 10.8.1.0 0.0.0.7 area 0
enable
config t
hostname Paul-East-Router2
interface GigabitEthernet 0/0
no shutdown
ip address 10.8.1.21 255.255.255.252
exit
interface GigabitEthernet 0/1
no shutdown
ip address 10.8.20.1 255.255.255.0
router ospf 1
network 10.8.1.20 0.0.0.3 area 0
network 10.8.20.0 0.0.0.255 area 0
enable
config t
hostname Paul-DataCenter-Router3
interface GigabitEthernet 0/0
no shutdown
ip address 10.8.1.22 255.255.255.252
exit
interface GigabitEthernet 0/1
no shutdown
ip address 10.8.1.33 255.255.255.252
exit
interface GigabitEthernet 0/2
no shutdown
ip address 10.8.1.2 255.255.255.248
exit
router ospf 1
network 10.8.1.0 0.0.0.7 area 0
network 10.8.1.32 0.0.0.3 area 0
network 10.8.1.20 0.0.0.3 area 0
enable
config t
hostname Paul-West-Router4
interface GigabitEthernet 0/0
no shutdown
ip address 10.8.1.34 255.255.255.252
exit
interface GigabitEthernet 0/1
no shutdown
ip address 10.8.40.1 255.255.255.0
exit
router ospf 1
network 10.8.1.32 0.0.0.3 area 0
network 10.8.40.0 0.0.0.255 area 0